Friday, 19 May 2017

VS.NET with Docker Compose - client version 1.22 is too old. Minimum supported API version is 1.24, please upgrade your client to a newer version

When creating an ASPNETCore project with Docker Compose support, on building I got the following error:

docker-compose -f "C:\Source Code\Test Projects\AspNetCore\docker-compose.yml" -f "C:\Source Code\Test Projects\AspNetCore\docker-compose.override.yml" -f "C:\Source Code\Test Projects\AspNetCore\docker-compose.vs.release.yml" -p dockercompose4184813946 kill
    client version 1.22 is too old. Minimum supported API version is 1.24, please upgrade your client to a newer version

Yet running docker-compose version in a PowerShell prompt returns:

Client:
 Version:      17.03.1-ce
 API version:  1.27
 Go version:   go1.7.5
 Git commit:   c6d412e
 Built:        Tue Mar 28 00:40:02 2017
 OS/Arch:      windows/amd64

Thankfully this article solves the problem. Because my tools are so new, there is an incompatibility with slightly older files produced by the VS.NET template.

The solution is to add
version: '2.1'
to the top of the docker-compose.yml file.

No comments:

Post a comment